ShakaCode | ShakaCode Blog | Rails On Maui Blog | Rails | ReactJs | JavaScript | Webpack | Productivity |

Yarn warnings (incorrect peer dependency) from install to new app following instructions


#1

I am getting lots of warnings from yarn when I install react_on_rails following the gem home page instructions.
Started with clean directory. Used instructions as given (+ bundle install, + git add -A + git commit)

Here is the list:

warning "babel-loader@7.1.2" has incorrect peer dependency "babel-core@6 || 7 || ^7.0.0-alpha || ^7.0.0-beta || ^7.0.0-rc".
warning "babel-loader@7.1.2" has incorrect peer dependency "webpack@2 || 3".
warning "coffee-loader@0.8.0" has incorrect peer dependency "coffeescript@>= 1.8.x".
warning "compression-webpack-plugin@1.0.0" has incorrect peer dependency "webpack@^2.0.0 || ^3.0.0".
warning "extract-text-webpack-plugin@3.0.0" has incorrect peer dependency "webpack@^3.1.0".
warning "postcss-cssnext@3.0.2" has incorrect peer dependency "caniuse-lite@^1.0.30000697".
warning "rails-erb-loader@5.2.1" has incorrect peer dependency "webpack@^2.0.0 || >= 3.0.0-rc.0 || ^3.0.0".
warning "sass-loader@6.0.6" has incorrect peer dependency "node-sass@^4.0.0".
warning "sass-loader@6.0.6" has incorrect peer dependency "webpack@^2.0.0 || >= 3.0.0-rc.0 || ^3.0.0".
warning "webpack-manifest-plugin@1.3.2" has incorrect peer dependency "webpack@1 || 2 || 3".
warning "ajv-keywords@2.1.0" has incorrect peer dependency "ajv@>=5.0.0".
warning "uglifyjs-webpack-plugin@0.4.6" has incorrect peer dependency "webpack@^1.9 || ^2 || ^2.1.0-beta || ^2.2.0-rc || ^3.0.0".
warning "react-on-rails@9.0.2" has incorrect peer dependency "babel-runtime@>= 6".
warning "react-redux@5.0.6" has unmet peer dependency "redux@^2.0.0 || ^3.0.0".
warning "webpack-dev-server@2.8.2" has incorrect peer dependency "webpack@^2.2.0 || ^3.0.0".
warning "webpack-dev-middleware@1.12.0" has incorrect peer dependency "webpack@^1.0.0 || ^2.0.0 || ^3.0.0".

Should I be following up these missing dependencies? The hello_world app ran, but each time I add another library I get the same warnings.

thanks,
Anita