ShakaCode | ShakaCode Blog | Rails On Maui Blog | Rails | ReactJs | JavaScript | Webpack | Productivity |

Webpacker fails compiling an unnecessary node-sass test file in a Rails app


#1

i try to recompile my app, but i get some errors about node-sass
I, [2018-11-09T11:40:51.877295 #7767] INFO – : Writing /home/cpu19/Desktop/sokuhaku/public/assets/node-sass/test/fixtures/cwd-include-path/outside-16530df24aa2a3e5905c030234516070ccef9ffe0f42b8fd452a5338651968c8.css.gz
rake aborted!
Sass::SyntaxError: File to import not found or unreadable: outside.
Load paths:
/home/cpu19/Desktop/app/assets/config
/home/cpu19/Desktop/app/assets/images
/home/cpu19/Desktop/app/assets/javascripts
/home/cpu19/Desktop/app/assets/slider-pro-master
/home/cpu19/Desktop/app/assets/stylesheets
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/select2-rails-4.0.3/vendor/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/select2-rails-4.0.3/vendor/assets/stylesheets
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/images
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/stylesheets
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/vendor/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/pickadate-rails-3.5.6.0/vendor/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/pickadate-rails-3.5.6.0/vendor/assets/stylesheets
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/jquery-rails-4.3.1/vendor/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/toastr-rails-1.0.3/vendor/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/toastr-rails-1.0.3/vendor/assets/stylesheets
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/coffee-rails-4.2.2/lib/assets/javascripts
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/actioncable-5.1.5/lib/assets/compiled
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/actionview-5.1.5/lib/assets/compiled
/home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/turbolinks-source-5.1.0/lib/assets/javascripts
/home/cpu19/Desktop/sokuhaku/node_modules
/home/cpu19/Desktop/sokuhaku/node_modules/node-sass/test/fixtures/cwd-include-path/root/index.scss:1
/home/cpu19/.rbenv/versions/2.5.1/bin/bundle:23:in load' /home/cpu19/.rbenv/versions/2.5.1/bin/bundle:23:in

Caused by:
Sass::SyntaxError: File to import not found or unreadable: outside.
Load paths:
  /home/cpu19/Desktop/app/assets/config
  /home/cpu19/Desktop/app/assets/images
  /home/cpu19/Desktop/app/assets/javascripts
  /home/cpu19/Desktop/app/assets/slider-pro-master
  /home/cpu19/Desktop/app/assets/stylesheets
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/select2-rails-4.0.3/vendor/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/select2-rails-4.0.3/vendor/assets/stylesheets
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/images
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/app/assets/stylesheets
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/ckeditor-4.2.4/vendor/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/pickadate-rails-3.5.6.0/vendor/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/pickadate-rails-3.5.6.0/vendor/assets/stylesheets
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/jquery-rails-4.3.1/vendor/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/toastr-rails-1.0.3/vendor/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/toastr-rails-1.0.3/vendor/assets/stylesheets
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/coffee-rails-4.2.2/lib/assets/javascripts
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/actioncable-5.1.5/lib/assets/compiled
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/actionview-5.1.5/lib/assets/compiled
  /home/cpu19/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/turbolinks-source-5.1.0/lib/assets/javascripts
  /home/cpu19/Desktop/sokuhaku/node_modules
/home/cpu19/.rbenv/versions/2.5.1/bin/bundle:23:in `load'
/home/cpu19/.rbenv/versions/2.5.1/bin/bundle:23:in `<main>'
Tasks: TOP => assets:precompile
(See full trace by running task with --trace)

I don’t know why its trying to compile a test file “node-sass/test/fixtures”.