React on Rails setup

I’m setting a React on Rails project following the documentation:, but when I run: rails webpacker:install or bundle exec rails webpacker:install it throws /home/dangelo/.rbenv/versions/3.1.2/bin/ruby: No such file or directory -- /home/dangelo/Desktop/things/The (LoadError) .

I have been searching to solve this issue but I can’t found any solution, inclusive I created a new project with webpacker gem (to check if my enviroment have any problem with that) and rails webpacker:install the installation works but ussing shakapacker gem dosn’t work

The react on rails generator works

My repo: Dangelo-JAN/test-react-on-rails repo

Thanks: Dangelo Arrivillaga

AFAIK, @ahangarha has solved this issue.

@Dangelo-JAN are you using current versions of Shakapacker and React on Rails?

Yes, This is my env setup:

  • Ruby version: 3.1.2p20
  • Rails version:
  • Shakapacker version: 6.5
  • React on Rails version: 13.2.0

Inclusive I followed @ahangarha setup but is the same issue when I run rails webpacker:install

I wonder why?

Have you tried Hotwire?

@Dangelo-JAN Sorry for my late reply

I just ran your project locally, and it seems you have been able to fix the issue. I assume you could figure out the problem. I would appreciate it if you could share what was going wrong.