ShakaCode | ShakaCode Blog | Rails On Maui Blog | Rails | ReactJs | JavaScript | Webpack | Productivity |

El Capitan Upgrade Tips


#1

Here’s a few notes on errors I got after updating to El Capitan and fixes:

Capybara-webkit

gem install capybara-webkit                                                                                                                                                                          ✹ ✭ [15:01:49]
Building native extensions.  This could take a while...
ERROR:  Error installing capybara-webkit:
	ERROR: Failed to build gem native extension.

    /Users/justin/.rvm/rubies/ruby-2.2.3/bin/ruby -r ./siteconf20151013-85269-1kengc0.rb extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
	--with-opt-dir
	--without-opt-dir
	--with-opt-include
	--without-opt-include=${opt-dir}/include
	--with-opt-lib
	--without-opt-lib=${opt-dir}/lib
	--with-make-prog
	--without-make-prog
	--srcdir=.
	--curdir
	--ruby=/Users/justin/.rvm/rubies/ruby-2.2.3/bin/$(RUBY_BASE_NAME)
	--with-gl-dir
	--without-gl-dir
	--with-gl-include
	--without-gl-include=${gl-dir}/include
	--with-gl-lib
	--without-gl-lib=${gl-dir}/lib
	--with-zlib-dir
	--without-zlib-dir
	--with-zlib-include
	--without-zlib-include=${zlib-dir}/include
	--with-zlib-lib
	--without-zlib-lib=${zlib-dir}/lib
Command '/usr/local/Cellar/qt5/5.4.0/bin/qmake ' not available

Turns out the issue is that I have a newer version of QT:

ls -l /usr/local/Cellar/qt5                                                                                                                                                                      1 ↵ ✹ ✭ [14:54:42]
total 0
drwxr-xr-x  23 justin  admin  782 Oct 11 11:23 5.5.0_1

So I created a sym link:

/usr/local/Cellar/qt5 (master) ln -s 5.5.0_1 5.4.0

That’s a work around until I figure out how to address the root cause.

I reported this issue on the issues page for capybara-webkit


#2

mysql issues

You might get an error message like this:

LoadError: dlopen(/Users/justin/.rvm/gems/ruby-2.2.3@paynearme/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle, 9): Library not loaded: libmysqlclient.18.dylib
  Referenced from: /Users/justin/.rvm/gems/ruby-2.2.3@paynearme/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle
  Reason: image not found - /Users/justin/.rvm/gems/ruby-2.2.3@paynearme/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle

Here’s the fix:

sudo install_name_tool -change libmysqlclient.18.dylib /usr/local/mysql/lib/libmysqlclient.18.dylib /Users/justin/.rvm/gems/ruby-2.2.3@paynearme/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle

This is explained here:

Note, you need to substitute the values above:

  • libmysqlclient.18.dylib
  • location of where where referenced, using the full path

#3

For what it’s worth, I’ve had to play around with contrast and brightness settings in the control panel and on my external monitors, using a Macbook Pro 2015. Seems that El Capitan is making the monitors dimmer to save power.


#4

When installing a homebrew package that requires OpenSSL, you’ll get an error because Apple removed the OpenSSL libraries in El Capitan.

To get around this, use the flag --with-brewed-open-ssl, assuming you’ve installed openssl with homebrew.

Example:

brew install git --with-brewed-openssl

#5

First, my upgrade to 11.1.1 fails. It hangs and eventually I hard reboot, and then the upgrade seems to finish OK. This was horrifying.

Just did a bunch of YAK SHAVING post 11.1.1!

  1. Eventually figured out that the only way I could get my USB3 hub in my P2715Q Dell 4K screen to show my external USB3 drives was to move the cable from the left side of my Macbook to the right side. Yes. No joke. I haven’t tried rebooting yet…Maybe that might fix this one.
  2. I could not get my key mappings to a couple desktops working after the upgrade. I finally solved the issue by deleting the 14th and 15th desktops and remapping the keystrokes.

This is serious desperation yak shaving, got to fix something annoying. Torture.


#6

I haven’t upgraded yet, do you think I should go ahead and get it over with?


#7

Maybe wait until a another set of patches. 10.11.1 is what I have.


#8

I personally had very few issues migrating to El Capitan. Brew+Node+rbenv didn’t bork when I upgraded, or when installing to a fresh El Capitan install.